在 CentOS6 升級 php5.3 至 php5.6
  • 1,382 views,
  • 2016-10-20,
  • 上傳者: 洪國恩,
  •  0
b1db21a8faf667bac1cf55f631b3bcfb.png
PHP5.3 已經存在很久了,而且在 2014 年八月就停止 support 了 (http://php.net/eol.php)。但還是很多 webapp 是用 php5.3 寫的,如果要升級上去可能需要不少 cost。
最好的方法就是先建一個測試站,然後確認是否能夠升級上去,或是升級上去後需要調整那些語法,以下介紹一個簡單的方式,萬一升級失敗也可以快速回復喔~
步驟
1.
加入 epel 的 repository
rpm -Uvh https://dl.fedoraproject.org/pub/epel/epel-release-latest-6.noarch.rpm
rpm -Uvh https://mirror.webtatic.com/yum/el6/latest.rpm
2.
先安裝 yum 的 replace plugin
yum install yum-plugin-replace
3.
換到 php56w 
yum replace php-common --replace-with=php56w-common
4.
萬一出問題,可以這樣切換回來
yum replace php56w-common --replace-with=php-common
Facebook 討論區載入中...
資料夾 :
標籤 :
發表時間 :
2016-10-20 08:32:00
觀看數 :
1,382
發表人 :
洪國恩
部門 :
老洪的 IT 學習系統
QR Code :